bash: syntax error near unexpected token ‘(‘

Published by:

PROBLEM: When changing directory in wine for “Program Files (x86)” you received the error message:
  bash: syntax error near unexpected token ‘(‘

SOLUTION(s): You have to escape the parenthesis by typing backslash (\).

cd Program\ Files\ \(x86\)

bash_sytax_error_near_unexpected_token

 

CREDITS: Thanks to lgarzo of StackExchange for providing the solution.

 

Cannot Register the Hard Drive Because a Hard Drive with UUID Already Exists

Published by:

PROBLEM:  Failed to open the disk image file <Path>. Cannot register the hard disk <Path> <GUID> because a hard disk <DifferentFilePath> with UUID <GUID> already exists.

failed_to_open_the_disk_image_file

FINDINGS: This happen when you copy an image file from another location and add this VM to virtualbox.

SOLUTION:

  1. Open command prompt (Hold windows+ r then type cmd).
  2. Change directory to where the Virtualbox is installed (e.g. c:\program files\Oracle\VirtualBox).
  3. type the command vboxmanage.exe internalcommands sethduuid <Path of new virtual HardDisk>

failed_to_open_the_disk_image_file_

 

 

APPLICABLE TO: VIRTUALBOX

CREDITS:  Thanks to Bradley Schacht for providing the solution.

 

 

 

 

Inbound TCP connection denied from to flags SYN on interface

Published by:

PROBLEM: Inbound TCP connection denied from 192.168.1.2:4523 to 192.168.20.25:443 flags SYN on interface <Interface Name>

FINDINGS: The security-level is the same on both interface.

SOLUTION(s): 

We can configure “same-security-traffic permit inter-interface” on the global configuration but this is not recommended. Because it will allow communication between same security interfaces. It will let traffic flow freely between all same security-level interfaces without access lists.

So our solution is to change the “security-level” of one interface. Example, if you have two interfaces with “security-level 50” configuration, you change the less secure interface to “security-level 40“.

Example configuration:

From:

interface GigabitEthernet0/1
nameif LAN1
 security-level 50
ip address 192.168.1.1 255.255.255.0

interface GigabitEthernet0/2
nameif LAN2
 security-level 50
ip address 192.168.20.1 255.255.255.0

 

To:

interface GigabitEthernet0/1
nameif LAN1
security-level 50
ip address 192.168.1.1 255.255.255.0

interface GigabitEthernet0/2
nameif LAN2
security-level 40
ip address 192.168.20.1 255.255.255.0

 

 

APPLICABLE TO: Cisco ASA or Cisco PIX of all models.

 

Disable SSL 3.0 in Internet Explorer

Published by:

You can easily disable SSL 3.0 in Internet Explorer by following the guide below.

  1. Hold Windows key+ r, then type inetcpl.cpl .
    Internet Explorer Option
  2.  Go to Advanced, scroll down and uncheck “Use SSL 3.0” option.

But if the system admin is restricting the access, you cannot do this guide.

checked_ssl_3-0_in_ie

 

We will disable this using registry.

  1. Hold Windows Key + r then type, regedit .
  2. Navigate to [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\CurrentVersion\Internet Settings].
  3. In the right pane, look for “SecureProtocols”=dword: 0x00000aa0 ssl3-0_registry_checked
  4. Change the value from aa0 to a80ssl3-0_registry_unchecked
  5. Close the registry and check if the SSL 3.0 has been unchecked from Internet Explorer.

unchecked_ssl_3-0_in_ie

Skip to toolbar